WK CRD 2011 Doesn't always start(oil light on) [Archive] - AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand

PDA

View Full Version : WK CRD 2011 Doesn't always start(oil light on)


WITHY
25-10-2011, 08:48 PM
Hi Everyone

Just again a recurring problem with the Jeep.On 3 different occasions 1 to 2 weeks apart (approx).
Jump in the car.
pressed the starter.
car idols for about a second, oil light comes on and stays on, vehicle stops.
Can repeat this scenario over and over again.
Get out of car lift out dipstick and place back in.
Jump in car press starter, vehicle starts no problems .
Dealer can't explain anything said they'll look at it in 1st service(When they also replace the battery with an upgraded one supposably).
It's just a concern as it's now happened to my wife tonight and over the phone I ran her through the process.
Has this occured to anyone else.

Thankyou Mike.:-?

ausjeeper
25-10-2011, 09:14 PM
You can try to read the error codes on the dash:
check engine codes (http://www.jeepforum.com/forum/f309/check-engine-2011-jeep-grand-cherokee-laredo-1154472/)
Cheers

gawdzinner
25-10-2011, 11:17 PM
could be the crank position sensor, http://www.300cforums.com/forums/european-diesel-powered-300-models/94527-startproblems-when-cold-3-0l-crd.html

WITHY
26-10-2011, 05:06 PM
could be the crank position sensor, http://www.300cforums.com/forums/european-diesel-powered-300-models/94527-startproblems-when-cold-3-0l-crd.html

Shall mention to dealer can't hurt.

Mike.

WITHY
26-10-2011, 05:24 PM
You can try to read the error codes on the dash:
check engine codes (http://www.jeepforum.com/forum/f309/check-engine-2011-jeep-grand-cherokee-laredo-1154472/)
Cheers

Will have to see how it can be checked with the starter button setup.

Thanks

Mike.

yoda42
26-10-2011, 07:16 PM
Hi Withy
Yoda from Darwin here, we have the same issue with our GC ( on two occasions)
I found on one of the us forums a good description from a guy with a V8 GC, but did not save page and now can't find it again, they were talking about fuel pump and keyless entry module.
Here is what happens to me
Push start button, engine starts and runs for about 1 or 2 seconds then stops, as it stops a red lightning bolt shows in the MIL then the oil light comes up, if you try to start it again and same thing happens, the brake pedal gets very hard, can try this 5 or 6 times and same result
What I have been doing is turn it off get out lock it and walk away ten meters or so then then come back and go through start procedure again, some times it works first time, I have had it take up to three times.
First time it happened, once it started again, I took it straight to the dealer and had then check for codes, they said there were none ( but it is Kerry's in Darwin ).
I have since found this http://www.wk2jeeps.com/tsb/tsb_wk2_0802411a.pdf, but the problem has not happened again for me to try pulling fuse M27, I hope this will work as then there is a known fix
I am leaning towards the keyless entry module as the act of shutting down and locking the car would reset its tiny brain, and this seems to be working for me

Give the fuse pulling a go if yours stops again and let us know if it works, I'll post if it happens to me

I also find this helpful http://www.wk2jeeps.com/wk2_tsb.htm#NEW, doesn't always apply but gives you an idea and puts the dealer on the right track

Cheers Yoda

Sorry for the novel :D