Wh Grand Cherokee Common Faults And Issues - Page 3 - AUSJEEPOFFROAD.COM - AJOR

Freight Management Australia
Find out how to advertise on Ausjeep?

Go Back   AUSJEEPOFFROAD.COM - AJOR > JEEP GARAGE > XH Commander and WH Grand Cherokee


Portal Register Forums Trading Your Jeep New Garage Mark All Read

Post New Thread  Reply
 
Thread Tools Search this Thread
  #17  
Old 04-01-2009
popeyeroo's Avatar
popeyeroo  popeyeroo is offline
Established Member
 
Join Date: May 2008
Location: s-west W.A
Posts: 108
What Jeep do I drive?: WH
Likes: 0
Liked 0 Times in 0 Posts
Default

BODY EXTERIOR -
- bonnet out of alignment

INTERIOR -
- Cloth seats stain very easy. TSB on this for the dealer to wash for you once.
- Rear seats creak at the latches
- Air control doesnt turn air off for feet-always on
ENGINE -
3.0 CRD -
- Swirl motor for the Turbo may make a clattering noise as this is the vaccum pump on the blink. Also delivers very poor performance.
- Injectors need to be reprogramed when they are replaced or they will not talk to the computer.
- seal on the inlet of the turbo lossens and causes an oil leak from the induction. fix: keep the hose clamp tight or fit new seal
- Turbo wind between 1500 & 3,000 rpm
3.7 -
4.7 -
5.7 -
- Is a known HEMI shudder but not sure if this affects the export model.
6.1 -

TRANSMISSION - QuadraTrac (QT) or QuadraDrive (QD)
- Service 4WD System light will illuminate and chime regularly. TSB to re flash and tighten connectors
- gearbox oil leak
- trans wiring harness seals leak trans oil on a regular basis.. updated adaptor fixes this problem (we hope)
- Couple of reported cases where the transmission has overheated shutting down the car for 15 minutes until temp comes down. This was on the sand in hot weather.


TRANSFER CASE -

SUSPENSION -
- Rear spring mount isolators creak/squeak, TSB fix for replacement isolators

STEERING -

ELECTRICS and ELECTRONICS -
- PCM eaten by battery acid. This is of note and has happened to me as an isolated case. The battery was either overcharging or leaked during servicing and hence the PCM is directly under the battery and it ate the aluminium cover and the PCB within. This caused no end of fault codes as well. Also the wiring harness on the left hand side facing forward of the vehicle had to be replaced due to the acid ingress.
- Window regulators on the front needed replacing
- Air Bag Light that go off & on again loose connection that 2 dealers 3 visit have failed to find.
- no blue wire for electric brakes discont. in WH
- gps touch screen calibration failed



WHEELS and BRAKES -
- Brake Rotors need machining front
- Minor shudder when braking uphill - possible TSB for this.
- pads and front skim at <40000km
ACCESSORIES -
- If you fit the factory nudge bar you cant fit the factory rated recovery points at the same time.
- if u fit the factory nudgebar on a car with parktronic, it sends the parktronic crazy cause the nudge bar goes straight over the sensors


MISC -
- creaking in front door rubbers
  #18  
Old 14-03-2009
cnstr  cnstr is offline
I just registered
 
Join Date: Dec 2008
Posts: 7
What Jeep do I drive?: None
Likes: 0
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by kimamigo View Post
My ZG regularly gets 1000ks out of a single tank......Kim
Hi Kim,

I have to ask, how do you get 1000k's out of a tank.

I'm lucky to get 550 from mine.

Bought the ZG just over a month ago, and have so far hade to fix the air-con, and now having a problem with the remote. Doesn't help that the guy I bought it from only had 1 remote, but hey. For the weekend she's going to be at the shopping centre
  #19  
Old 15-03-2009
kimamigo's Avatar
kimamigo  kimamigo is offline
Established Member
 
Join Date: Oct 2005
Location: Sunshine Coast
Posts: 228
What Jeep do I drive?: WH
Likes: 0
Liked 0 Times in 0 Posts
Default

The ZG regularly gets used between Brisbane and Emerald, (950 k's) and still has 70 odd k's on the distance to empty. It's been power/economy chipped, uses premium fuel exclusively, is in excellent condition and is serviced regularly by me. It helps when ya stick to the speed limits an use cruise. .....
.........kim
__________________
I understand it's a JEEP Thing.........
  #20  
Old 14-04-2009
neiljw  neiljw is offline
I just registered
 
Join Date: Jun 2008
Location: Melbourne
Age: 54
Posts: 10
What Jeep do I drive?: WH
Likes: 0
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by popeyeroo View Post
WH Grand 5.7 Hemi
42000 km so far.

Sat nav screen calibration went out and the whole unit was replaced.
I have a very slight hemi shudder during light accel, i heard a jet chip fixes this and those odd unusual feeling gear changes.?

My rear seats creak where the latches lock to the chrome bars.- i always thought it was the rear susp but if i fold the seats down - no creak.

The interior air control doesnt turn off the air to your feet when dialled, this gives me icy feet and legs with aircon on.

Front brake pads totally worn out and the disks needed skimming at 40000 km.

Slight rear diff whine at 100km and light load.
I put a Jet chip in my 2005 WH 5.7L and it ran beautifully, great throttle response and better response with gear changes (no lag). It ran like that for several weeks, then I was getting jerky throttle response and a warning light came on "electronic throttle control error". Also the quick shift operation on the auto transmission stopped working. I removed the Jet chip and all returned to normal. I'd like to put the chip back in and take it to Jeep to re-map the ECM but I don't know if Jeep will touch it. Does anybody know how Chrysler / Jeep will react if I request a service with the Jet chip in.? Failing that, does anybody know where I can get it serviced or tuned by a Jeep savvy auto shop in Melb.??
Sponsored Posts
  #21  
Old 14-04-2009
Roachy's Avatar
Roachy  Roachy is offline
Full Flexer
 
Join Date: Sep 2003
Location: Wagga
Posts: 757
What Jeep do I drive?: WK2
Likes: 1
Liked 3 Times in 3 Posts
Default

Quote:
Originally Posted by neiljw View Post
I put a Jet chip in my 2005 WH 5.7L and it ran beautifully, great throttle response and better response with gear changes (no lag). It ran like that for several weeks, then I was getting jerky throttle response and a warning light came on "electronic throttle control error". Also the quick shift operation on the auto transmission stopped working. I removed the Jet chip and all returned to normal. I'd like to put the chip back in and take it to Jeep to re-map the ECM but I don't know if Jeep will touch it. Does anybody know how Chrysler / Jeep will react if I request a service with the Jet chip in.? Failing that, does anybody know where I can get it serviced or tuned by a Jeep savvy auto shop in Melb.??
I would think that Jeep would not want to know about it. The problem with the Jet unit (and all the other piggy back units) is that the ECM 'learns' around it and eventually negates the Jet unit. You really want to get a reprogrammer like a Superchips unit which you just plug in and reprogram the ECU and then unplug before driving.
  #22  
Old 19-05-2009
johnv's Avatar
johnv  johnv is offline
AJOR Silver
 
Join Date: Oct 2005
Location: Ballarat, VIC
Posts: 477
What Jeep do I drive?: None
Likes: 0
Liked 1 Time in 1 Post
Default Help - Non Adjustable Suspension WH

Is this a common issue with WH models?
My vehicle has just ticked over 30,000Km, it has been behaving in this manner since about 8,000Km, when it had an OME 50mm lift kit installed.

Front left wheel is out of alignment and scrubbing the tyre on the outside edge. It wants to keep driving left all the time.

Have had it into a wheel alignment specialist who tells me that this is a common problem with the previous WJ model. Says there is an offset bush to fix?

I am not knowledgable in wheel alignment technicalities, the settings from the report as below (front only)

Caster - left 3deg38' - right 3deg51'
Camber - left 0deg50' - right 0deg09'
Toe - left 0deg01' - right 0deg02'

I understand that there is quite a variation in the numbers, however what it means except that it pulls left is beyond my scope, would certainly apprecaite some advice / feedback - is this a common problem with WH??

A. should this be a warranty issue?
B. how best to fix the problem and where can I get parts if that's what's required?
__________________
Regards johnv,
Sponsored Posts
  #23  
Old 19-05-2009
DarwinDave  DarwinDave is offline
Established Member
 
Join Date: Aug 2004
Location: Brisbane
Posts: 106
What Jeep do I drive?: WH
Likes: 0
Liked 1 Time in 1 Post
Default

Hi John,

DarwinDave here again, I've had no problems at all with my 2"OME lift. I had a minor problem early on as I couldn't get the front struts and had to use the original ones for a couple of months. On the way to Darwin I topped them out on the rough road and they rubbed on the body all the way up and back but after the fitting of the Bilstiens and the corresponding wheel alignment, no trouble at all.
I've done 38,000 and the original tyres still have probably 5-10 left but they will not see it out.
I've had a rear oil seal replaced and the crankshaft sensor gave up the goast one morning in the middle of Samford road in peak traffic, a bit interesting. But after it sat for about 20 mins it started and I was able to get to the dealer to fix it. This is reported as a major fault on the US Jeep Forum site.

Cheers
DarwinDave
__________________
DarwinDave (Now in Brisbane)
2007 WH CRD
  #24  
Old 19-05-2009
johnv's Avatar
johnv  johnv is offline
AJOR Silver
 
Join Date: Oct 2005
Location: Ballarat, VIC
Posts: 477
What Jeep do I drive?: None
Likes: 0
Liked 1 Time in 1 Post
Default

Hi Dave, I have spoken to the Jeep dealership in Townsville, they will look at it next week while it is there getting the door window modules replaced due to erratic behaviour it has a TSB.
I have had it into various dealerships and they just spray the tracks with silicone, until you complain loud enough then it becomes a warranty repair issue.
I am hoping someone on this furum can give me some technical advice as to why it is doing this (pulling left) and what the fix may be?
Are there any mechanics "in the house"??
My tyres are starting to get down too, I was hoping to sell them but that's pretty much expired now, I look like having a spare road carcase.
all the best, johnv
__________________
Regards johnv,
Post New Thread  Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On





All times are GMT +10. The time now is 11:55 PM.




AJOR does not vouch for or warrant the accuracy, completeness or usefulness of any message, and are not responsible for the contents of any message. The messages express the views of the author of the message, not necessarily the views of AJOR or any entity associated with AJOR, nor should any advice be substituted as technical advice replacing that of a mechanic. You agree, through your use of this service, that you will not use AJOR to post any material which is knowingly false and/or defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, religious, political or otherwise violative of any law. You agree not to post any copyrighted material unless the copyright is owned by you or by AJOR. The owner, administrators and moderators of AJOR reserve the right to delete any message or members for any or no reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold harmless AJOR, the administrators, moderators, and their agents with respect to any claim based upon transmission of your message(s). The use of profile signatures to intentionally mislead or misdirect any member on this forum is not acceptable and may result in your account being suspended. Any trip that is organised through the AJOR forum is participated at your own risk. If you or your vehicle is damaged it is your responsibility, not that of the person that posted the thread, message or topic initiating the trip, nor the organisers of AJOR or moderators of any specific forum. This forum and associated website is the property of AJOR.





Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

AJOR 2002 - 2017 AUSJEEPOFFROAD.COM. All corporate trademarked names and logos are property of their respective owners. Ausjeepoffroad is in no way associated with DaimlerChrysler Corporation or Fiat Jeep.
www.midlifemate.com wayalife.com jkwrangler.com ausjeepforum.com jk-forum.com canadianjeepoffroad.com 20secondgorilla.com
vB Ad Management by =RedTyger=