Wh Grand Cherokee Common Faults And Issues - Page 3 - AUSJEEPOFFROAD.COM - AJOR


Go Back   AUSJEEPOFFROAD.COM - AJOR > JEEP GARAGE > XH Commander and WH Grand Cherokee


Portal Register Forums Trading Your Jeep New Garage Mark All Read

Post New Thread  Reply
 
Thread Tools Search this Thread
  #19  
Old 15-03-2009
kimamigo's Avatar
kimamigo  kimamigo is offline
Established Member
 
Join Date: Oct 2005
Location: Sunshine Coast
Posts: 228
What Jeep do I drive?: WH
Likes: 0
Liked 0 Times in 0 Posts
Default

The ZG regularly gets used between Brisbane and Emerald, (950 k's) and still has 70 odd k's on the distance to empty. It's been power/economy chipped, uses premium fuel exclusively, is in excellent condition and is serviced regularly by me. It helps when ya stick to the speed limits an use cruise. .....
.........kim
__________________
I understand it's a JEEP Thing.........
  #20  
Old 14-04-2009
neiljw  neiljw is offline
I just registered
 
Join Date: Jun 2008
Location: Melbourne
Age: 53
Posts: 10
What Jeep do I drive?: WH
Likes: 0
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by popeyeroo View Post
WH Grand 5.7 Hemi
42000 km so far.

Sat nav screen calibration went out and the whole unit was replaced.
I have a very slight hemi shudder during light accel, i heard a jet chip fixes this and those odd unusual feeling gear changes.?

My rear seats creak where the latches lock to the chrome bars.- i always thought it was the rear susp but if i fold the seats down - no creak.

The interior air control doesnt turn off the air to your feet when dialled, this gives me icy feet and legs with aircon on.

Front brake pads totally worn out and the disks needed skimming at 40000 km.

Slight rear diff whine at 100km and light load.
I put a Jet chip in my 2005 WH 5.7L and it ran beautifully, great throttle response and better response with gear changes (no lag). It ran like that for several weeks, then I was getting jerky throttle response and a warning light came on "electronic throttle control error". Also the quick shift operation on the auto transmission stopped working. I removed the Jet chip and all returned to normal. I'd like to put the chip back in and take it to Jeep to re-map the ECM but I don't know if Jeep will touch it. Does anybody know how Chrysler / Jeep will react if I request a service with the Jet chip in.? Failing that, does anybody know where I can get it serviced or tuned by a Jeep savvy auto shop in Melb.??
Sponsored Posts
  #21  
Old 14-04-2009
Roachy's Avatar
Roachy  Roachy is offline
Full Flexer
 
Join Date: Sep 2003
Location: Wagga
Posts: 753
What Jeep do I drive?: WK2
Likes: 1
Liked 3 Times in 3 Posts
Default

Quote:
Originally Posted by neiljw View Post
I put a Jet chip in my 2005 WH 5.7L and it ran beautifully, great throttle response and better response with gear changes (no lag). It ran like that for several weeks, then I was getting jerky throttle response and a warning light came on "electronic throttle control error". Also the quick shift operation on the auto transmission stopped working. I removed the Jet chip and all returned to normal. I'd like to put the chip back in and take it to Jeep to re-map the ECM but I don't know if Jeep will touch it. Does anybody know how Chrysler / Jeep will react if I request a service with the Jet chip in.? Failing that, does anybody know where I can get it serviced or tuned by a Jeep savvy auto shop in Melb.??
I would think that Jeep would not want to know about it. The problem with the Jet unit (and all the other piggy back units) is that the ECM 'learns' around it and eventually negates the Jet unit. You really want to get a reprogrammer like a Superchips unit which you just plug in and reprogram the ECU and then unplug before driving.
  #22  
Old 19-05-2009
johnv's Avatar
johnv  johnv is offline
AJOR Silver
 
Join Date: Oct 2005
Location: Ballarat, VIC
Posts: 477
What Jeep do I drive?: None
Likes: 0
Liked 1 Time in 1 Post
Default Help - Non Adjustable Suspension WH

Is this a common issue with WH models?
My vehicle has just ticked over 30,000Km, it has been behaving in this manner since about 8,000Km, when it had an OME 50mm lift kit installed.

Front left wheel is out of alignment and scrubbing the tyre on the outside edge. It wants to keep driving left all the time.

Have had it into a wheel alignment specialist who tells me that this is a common problem with the previous WJ model. Says there is an offset bush to fix?

I am not knowledgable in wheel alignment technicalities, the settings from the report as below (front only)

Caster - left 3deg38' - right 3deg51'
Camber - left 0deg50' - right 0deg09'
Toe - left 0deg01' - right 0deg02'

I understand that there is quite a variation in the numbers, however what it means except that it pulls left is beyond my scope, would certainly apprecaite some advice / feedback - is this a common problem with WH??

A. should this be a warranty issue?
B. how best to fix the problem and where can I get parts if that's what's required?
__________________
Regards johnv,
Sponsored Posts
  #23  
Old 19-05-2009
DarwinDave  DarwinDave is offline
Established Member
 
Join Date: Aug 2004
Location: Brisbane
Posts: 106
What Jeep do I drive?: WH
Likes: 0
Liked 1 Time in 1 Post
Default

Hi John,

DarwinDave here again, I've had no problems at all with my 2"OME lift. I had a minor problem early on as I couldn't get the front struts and had to use the original ones for a couple of months. On the way to Darwin I topped them out on the rough road and they rubbed on the body all the way up and back but after the fitting of the Bilstiens and the corresponding wheel alignment, no trouble at all.
I've done 38,000 and the original tyres still have probably 5-10 left but they will not see it out.
I've had a rear oil seal replaced and the crankshaft sensor gave up the goast one morning in the middle of Samford road in peak traffic, a bit interesting. But after it sat for about 20 mins it started and I was able to get to the dealer to fix it. This is reported as a major fault on the US Jeep Forum site.

Cheers
DarwinDave
__________________
DarwinDave (Now in Brisbane)
2007 WH CRD
  #24  
Old 19-05-2009
johnv's Avatar
johnv  johnv is offline
AJOR Silver
 
Join Date: Oct 2005
Location: Ballarat, VIC
Posts: 477
What Jeep do I drive?: None
Likes: 0
Liked 1 Time in 1 Post
Default

Hi Dave, I have spoken to the Jeep dealership in Townsville, they will look at it next week while it is there getting the door window modules replaced due to erratic behaviour it has a TSB.
I have had it into various dealerships and they just spray the tracks with silicone, until you complain loud enough then it becomes a warranty repair issue.
I am hoping someone on this furum can give me some technical advice as to why it is doing this (pulling left) and what the fix may be?
Are there any mechanics "in the house"??
My tyres are starting to get down too, I was hoping to sell them but that's pretty much expired now, I look like having a spare road carcase.
all the best, johnv
__________________
Regards johnv,
Sponsored Posts
  #25  
Old 19-05-2009
DarwinDave  DarwinDave is offline
Established Member
 
Join Date: Aug 2004
Location: Brisbane
Posts: 106
What Jeep do I drive?: WH
Likes: 0
Liked 1 Time in 1 Post
Default

Hi John,
Try "http://www.jeepforum.com/forum/" then go to Grand Cherokee and Commander Forum Group then to WK & XK Technical Forum and send a request to Merlin for advice. He is a UK master Jeep technician.
There is a lot of very good info on that site.

Cheers
Dave
__________________
DarwinDave (Now in Brisbane)
2007 WH CRD
  #26  
Old 09-09-2009
irvs351's Avatar
irvs351  irvs351 is offline
Established Member
 
Join Date: Apr 2008
Location: Kalgoorlie WA
Age: 45
Posts: 168
What Jeep do I drive?: WH
Likes: 0
Liked 0 Times in 0 Posts
Default

I have had a recent issue with the windscreen wipers occasionally stopping mid screen. It started off they would occasionally slow down mid screen and then they started stopping always at the worst time. I replaced blades etc still no good. Spoke to local Jeep man and he said there is an issue with water ingress to a module under the fuse box covered under warranty. Any way I dropped it off for him to look at and they found the wiper linkages had rubbed through the wiring. It was repaired under warranty, the wiring was rerouted and Jeep Aust was informed. I don't know if this is a one off but I thought everyone should be aware as losing you wipers at night in the rain isn't fun.
__________________
WH Grand Cherokee Limited

Lukey 3" exhaust, LT265/75R17 BFG AT's and more mods to come
  #27  
Old 21-09-2009
GMEMUD's Avatar
GMEMUD  GMEMUD is offline
AJOR Gold
 
Join Date: Feb 2004
Location: BLACKWATER
Posts: 1,464
Likes: 8
Liked 29 Times in 26 Posts
Default

Johnv: I have the OME2" lift on the WH fitted at ARB Mackay and have no wheel alignment issues at all.
I did have a problem on the KJ though after the lift and it turned out to be one of the rear wheels had a different backspace to the others, hence throwing the alignment out.
__________________
WK2 Overland, KJ, CJ10, FC 170- '79 Chief, 52 Willys pick-up.
Post New Thread  Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On





All times are GMT +10. The time now is 07:07 PM.




AJOR does not vouch for or warrant the accuracy, completeness or usefulness of any message, and are not responsible for the contents of any message. The messages express the views of the author of the message, not necessarily the views of AJOR or any entity associated with AJOR, nor should any advice be substituted as technical advice replacing that of a mechanic. You agree, through your use of this service, that you will not use AJOR to post any material which is knowingly false and/or defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, religious, political or otherwise violative of any law. You agree not to post any copyrighted material unless the copyright is owned by you or by AJOR. The owner, administrators and moderators of AJOR reserve the right to delete any message or members for any or no reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold harmless AJOR, the administrators, moderators, and their agents with respect to any claim based upon transmission of your message(s). The use of profile signatures to intentionally mislead or misdirect any member on this forum is not acceptable and may result in your account being suspended. Any trip that is organised through the AJOR forum is participated at your own risk. If you or your vehicle is damaged it is your responsibility, not that of the person that posted the thread, message or topic initiating the trip, nor the organisers of AJOR or moderators of any specific forum. This forum and associated website is the property of AJOR.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

AJOR 2002 - 2017 AUSJEEPOFFROAD.COM. All corporate trademarked names and logos are property of their respective owners. Ausjeepoffroad is in no way associated with DaimlerChrysler Corporation or Fiat Jeep.
www.midlifemate.com wayalife.com jkwrangler.com ausjeepforum.com jk-forum.com canadianjeepoffroad.com
vB Ad Management by =RedTyger=