CRD oil warning light - AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand


Go Back   AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand > JEEP GARAGE > XH Commander and WH Grand Cherokee


Portal Register Forums Trading Your Jeep New Garage Mark All Read

Post New Thread  Reply
 
Thread Tools Search this Thread
  #1  
Old 1 Week Ago
shawry  shawry is offline
I just registered
 
Join Date: Jun 2012
Posts: 3
What Jeep do I drive?: KJ
Likes: 0
Thanked 2 Times in 1 Post
Unhappy CRD oil warning light

My WH CRD shows 150,00kms. Changed the engine oil and filter the other day and since have had intermittent oil warning light on dash. Only happens when engine hot and predominantly after RH corner and then maybe 50 m up the road.
I have replaced the oil pressure switch on the oil filter housing and disconnected what I believe is the oil temp. sender on rear of sump to no avail. The workshop manual indicates that there is an oil level sensor but I am stuffed if I can find it.
Anyone had similar issue and where to go from here?

PS Oil level okay, engine filled with 9.5L Penrite 5W40 synthetic.

Sponsored Posts
  #2  
Old 1 Week Ago
Clarky's Avatar
Clarky  Clarky is offline
Grand Obsession
 
Join Date: Apr 2012
Location: Wang NSW
Age: 50
Posts: 3,930
What Jeep do I drive?: WH
Likes: 367
Liked 870 Times in 578 Posts
Check out my Ride(s)
Default

Change out the oil filter again, you may have a dodgy one.
__________________
FORUM MODERATOR QuadraDrive II CRD 2"Lift +30 rims 255/75/17 BFG KO2's, Saguaro, Runva,
  #3  
Old 1 Week Ago
bjm  bjm is offline
Full Flexer
 
Join Date: Jun 2009
Location: yamba 2464 nsw
Posts: 532
What Jeep do I drive?: WH
Likes: 18
Liked 96 Times in 66 Posts
Default

I think the oil level and oil temp sender are all one unit.As Clarky said also maybe faulty oil filter,did you fit the small oring on the filter.? These sensors do fail ,more info on the Mercedes forum
  #4  
Old 6 Days Ago
shawry  shawry is offline
I just registered
 
Join Date: Jun 2012
Posts: 3
What Jeep do I drive?: KJ
Likes: 0
Thanked 2 Times in 1 Post
Default

Thanks guys, I have found the issue and it is a broken plastic centrepiece in the filter ie the small "o" ring is missing from the bottom end as per the similar thread posted today.
Likes: (2)
Sponsored Posts
Post New Thread  Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


» Advertisements_AS2




Powered by vBadvanced CMPS v3.2.3



All times are GMT +10. The time now is 09:49 PM.




AJOR does not vouch for or warrant the accuracy, completeness or usefulness of any message, and are not responsible for the contents of any message. The messages express the views of the author of the message, not necessarily the views of AJOR or any entity associated with AJOR, nor should any advice be substituted as technical advice replacing that of a mechanic. You agree, through your use of this service, that you will not use AJOR to post any material which is knowingly false and/or defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, religious, political or otherwise violative of any law. You agree not to post any copyrighted material unless the copyright is owned by you or by AJOR. The owner, administrators and moderators of AJOR reserve the right to delete any message or members for any or no reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold harmless AJOR, the administrators, moderators, and their agents with respect to any claim based upon transmission of your message(s). The use of profile signatures to intentionally mislead or misdirect any member on this forum is not acceptable and may result in your account being suspended. Any trip that is organised through the AJOR forum is participated at your own risk. If you or your vehicle is damaged it is your responsibility, not that of the person that posted the thread, message or topic initiating the trip, nor the organisers of AJOR or moderators of any specific forum. This forum and associated website is the property of AJOR.





Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

AJOR 2002 - 2018 AUSJEEPOFFROAD.COM. All corporate trademarked names and logos are property of their respective owners. Ausjeepoffroad is in no way associated with DaimlerChrysler Corporation or Fiat Jeep.
www.midlifemate.com wayalife.com jkwrangler.com ausjeepforum.com jk-forum.com canadianjeepoffroad.com cryptoprofitcalculator.net
vB Ad Management by =RedTyger=