Why is it hard to Start when Cold - Page 2 - AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand


Go Back   AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand > JEEP GARAGE > XJ / MJ Cherokee


Portal Register Forums Trading Your Jeep New Garage Mark All Read

Post New Thread  Reply
 
Thread Tools Search this Thread
  #10  
Old 03-06-2018
rustynuts's Avatar
rustynuts  rustynuts is offline
Trail Twister
 
Join Date: Jun 2014
Location: Sydney northern beaches
Posts: 1,829
What Jeep do I drive?: XJ
Likes: 2,424
Liked 840 Times in 479 Posts
Default

There is a fuel anti drain back valve on the pump. It may be letting fuel pressure back into the tank if it is leaking a bit.
__________________
Go hard. You can rest when you die
"98 XJ. RE 3.5 inch lift. Dana 44. 4.11's. 32's
  #11  
Old 05-06-2018
LuluBelle's Avatar
LuluBelle  LuluBelle is offline
Full Flexer
 
Join Date: Apr 2013
Location: Blackall Outback Queensland
Posts: 1,113
What Jeep do I drive?: XJ
Likes: 267
Liked 335 Times in 223 Posts
Default

Still haven't charged the battery But another Theory... I went to start it today and the dah lights flickered for a bit then settled down took 2 cranks once running perfect and the next starts....... now my 96 wiring is brittle to say the least I am now wondering if a wire when cold is a bit iffy connection wise when it warms up the connection expands and works now I had something simular happen on a ford once have to check over all the sensor wires .. that will be fun will look into it when my back feels a bit better
_____ooooo
/__l_l_,\____\,___
l_---l_l__l---[ ]llllll[ ]
_.(o)_)__(o)_)--o-)_)
__________________
NEW 96 XJ Limited LPG Conversion......as I Have Replaced EVERYTHING!
99 Sport
Sponsored Posts
  #12  
Old 07-06-2018
bonza's Avatar
bonza  bonza is offline
Lowranger Shocker
 
Join Date: Mar 2006
Location: Melbourne
Posts: 1,504
What Jeep do I drive?: TJ
Likes: 51
Liked 79 Times in 66 Posts
Default

Quote:
Originally Posted by rustynuts View Post
There is a fuel anti drain back valve on the pump. It may be letting fuel pressure back into the tank if it is leaking a bit.
thats my bet.

if like TJ Wranglers the check valve to stop fuel running back into the tank from the injectors is a semi integral part of the pump

if the valve has some leakage, fuel in the lines etc will run back to tank and you have to do a long crank or several to prime the fuel line and build up pressure before the injectors can squirt fuel into the cylinders for it to fire

with hotter temps, components within the check valve expand and form a seal, but when cold things shrink and allow leakage. we are only talking microns here, but thats all it takes for a leak

best way round it is to switch on the ignition and wait 10 seconds or so, this will allow the pump to run and build up pressure, then fully turn the switch to start

if this procedure cures your cold start then that proves the valve in the pump is a bit wonky. can stay like that for years without causing a problem
__________________
05 six speed khaki renegade
I like a man who grins when he fights—
Winston Churchill
  #13  
Old 27-06-2018
LuluBelle's Avatar
LuluBelle  LuluBelle is offline
Full Flexer
 
Join Date: Apr 2013
Location: Blackall Outback Queensland
Posts: 1,113
What Jeep do I drive?: XJ
Likes: 267
Liked 335 Times in 223 Posts
Default

been a bit warmer the last week the dash lights don't flicker as much first start only still turning the key on and off 3 times before I crank hot or cold .. cold starting is better finally got the fuel pressure tester I ordered off ebay will test tomorrow
_____ooooo
/__l_l_,\____\,___
l_---l_l__l---[ ]llllll[ ]
_.(o)_)__(o)_)--o-)_)
__________________
NEW 96 XJ Limited LPG Conversion......as I Have Replaced EVERYTHING!
99 Sport
Sponsored Posts
  #14  
Old 28-06-2018
LuluBelle's Avatar
LuluBelle  LuluBelle is offline
Full Flexer
 
Join Date: Apr 2013
Location: Blackall Outback Queensland
Posts: 1,113
What Jeep do I drive?: XJ
Likes: 267
Liked 335 Times in 223 Posts
Default

I got the missus to turn the key and 49psi but falls to 20 did it a few times same thing might be leaking ? also pulled all the engine fuses and relays out to reseat them found one 30 amp fuse a little bit wiggly slightly so I might replace that fuse see how we go once started it runs perfectly?
_____ooooo
/__l_l_,\____\,___
l_---l_l__l---[ ]llllll[ ]
_.(o)_)__(o)_)--o-)_)
__________________
NEW 96 XJ Limited LPG Conversion......as I Have Replaced EVERYTHING!
99 Sport
  #15  
Old 02-07-2018
LuluBelle's Avatar
LuluBelle  LuluBelle is offline
Full Flexer
 
Join Date: Apr 2013
Location: Blackall Outback Queensland
Posts: 1,113
What Jeep do I drive?: XJ
Likes: 267
Liked 335 Times in 223 Posts
Default

well information comes from the strangest places .....
I was watching tv this morning "wheeler dealers" and mike and ed had a merc which had cold start issues they talked about the "cold start valve" ? wtf?.....google some cars have it on the injectors or fuel rail ?....quick scan I then googled cold start valve on jeep Cherokee? never seen it before? turns out to be the map sensor and one of the symptoms is a flashing check engine light ok interesting as it only started doing it recently maybe ....... A the map sensor has gone bad or B the fragile well done 22 year old wiring was disturbed when the head was taken off ...
more investigation needed but a hint maybe from the strangest places .............
_____ooooo
/__l_l_,\____\,___
l_---l_l__l---[ ]llllll[ ]
_.(o)_)__(o)_)--o-)_)
__________________
NEW 96 XJ Limited LPG Conversion......as I Have Replaced EVERYTHING!
99 Sport
Sponsored Posts
  #16  
Old 02-07-2018
HamishW96's Avatar
HamishW96  HamishW96 is offline
Full Flexer
 
Join Date: May 2017
Location: Victoria
Posts: 661
What Jeep do I drive?: XJ
Likes: 236
Liked 82 Times in 61 Posts
Check out my Ride(s)
Default

There are vacuum lines to the map sensor. Double check these are in tact. Also clean you IAC sensor... Make sure all your vac lines are good and not cracked. I'd be cleaning all the connectors with contact cleaner and a brush before replacing the sensors
  #17  
Old 03-07-2018
LuluBelle's Avatar
LuluBelle  LuluBelle is offline
Full Flexer
 
Join Date: Apr 2013
Location: Blackall Outback Queensland
Posts: 1,113
What Jeep do I drive?: XJ
Likes: 267
Liked 335 Times in 223 Posts
Default

i wont be throwing a new map sensor at it just yet I unplugged it today and looked at the wiring into the plug the purple I think was a little loose hhmmmnnnn I thought didn't feel like pulling the plug apart today but worth considering I will look at it when I pull the throttle body off for a clean and check the iac in the next few days
_____ooooo
/__l_l_,\____\,___
l_---l_l__l---[ ]llllll[ ]
_.(o)_)__(o)_)--o-)_)
__________________
NEW 96 XJ Limited LPG Conversion......as I Have Replaced EVERYTHING!
99 Sport
  #18  
Old 09-07-2018
LuluBelle's Avatar
LuluBelle  LuluBelle is offline
Full Flexer
 
Join Date: Apr 2013
Location: Blackall Outback Queensland
Posts: 1,113
What Jeep do I drive?: XJ
Likes: 267
Liked 335 Times in 223 Posts
Default

went to Longreach again on Saturday cold early start and the jeep didn't want to start had to crank 5 or 6 times I thought I might flatten the battery anyway it started as usual once started straight to a perfect idle ?
ok I haven't got around to pulling the throttle body off as yet but I unplugged it and got the multimeter out and tested the voltage 4.5v to 5.2v all good within limits so the wires must be ok .............. so it must be the map sensor?
the check engine light didn't flicker while it was unplugged ............... so it must be the map sensor ?
while playing with the wires and map sensor I noticed that the throttle body has no gasket now I have had it off before and it never had a gasket but this time it sorta struck me I checked my hanes manual and there should be a gasket ? I was going to just get some thick gasket paper off the mechanics but decided to buy a you beaut gasket from rockauto for $1.80 aud silicone/aluminium blah blah postage $ 9.00 which is the killer but oh well ......
may be there is a air leak which is after the sensor? and cold =contraction and heat = expansion Im guessing so I will wait for the gasket to pull everything apart and clean
also if the map sensor was playing up wouldn't the car run roughish all the time ?
still a mystery
_____ooooo
/__l_l_,\____\,___
l_---l_l__l---[ ]llllll[ ]
_.(o)_)__(o)_)--o-)_)
__________________
NEW 96 XJ Limited LPG Conversion......as I Have Replaced EVERYTHING!
99 Sport
Post New Thread  Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


» Advertisements_AS2


Powered by vBadvanced CMPS v3.2.3



All times are GMT +10. The time now is 07:40 PM.




AJOR does not vouch for or warrant the accuracy, completeness or usefulness of any message, and are not responsible for the contents of any message. The messages express the views of the author of the message, not necessarily the views of AJOR or any entity associated with AJOR, nor should any advice be substituted as technical advice replacing that of a mechanic. You agree, through your use of this service, that you will not use AJOR to post any material which is knowingly false and/or defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, religious, political or otherwise violative of any law. You agree not to post any copyrighted material unless the copyright is owned by you or by AJOR. The owner, administrators and moderators of AJOR reserve the right to delete any message or members for any or no reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold harmless AJOR, the administrators, moderators, and their agents with respect to any claim based upon transmission of your message(s). The use of profile signatures to intentionally mislead or misdirect any member on this forum is not acceptable and may result in your account being suspended. Any trip that is organised through the AJOR forum is participated at your own risk. If you or your vehicle is damaged it is your responsibility, not that of the person that posted the thread, message or topic initiating the trip, nor the organisers of AJOR or moderators of any specific forum. This forum and associated website is the property of AJOR.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

AJOR © 2002 - 2019 AUSJEEPOFFROAD.COM. All corporate trademarked names and logos are property of their respective owners. Ausjeepoffroad is in no way associated with DaimlerChrysler Corporation or Fiat Jeep.
www.ausjeep.com www.ausjeep.com.au www.midlifemate.com ausjeepforum.com Jeep Wrangler JL Australia release
vB Ad Management by =RedTyger=