Jeep 2.7crd not starting - Page 3 - AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand


Go Back   AUSJEEPOFFROAD.COM Jeep News Australia and New Zealand > JEEP GARAGE > ZJ WJ WG Grand Cherokee


Portal Register Forums Trading Your Jeep New Garage Mark All Read

Post New Thread  Reply
 
Thread Tools Search this Thread
  #19  
Old 05-01-2019
Tinyprins's Avatar
Tinyprins  Tinyprins is offline
Newbie
 
Join Date: Dec 2018
Posts: 31
What Jeep do I drive?: WJ
Likes: 2
Liked 0 Times in 0 Posts
Default

Got a gauge to measure the rail pressure gauge only reads to 200bar but on crank it takes a while to build up pressure when the engine is not turning the pressure drops at a steady rate not keeping the rail pressure is a concern ..

Sent from my GT-I9500 using Tapatalk

It does go to max on this gauge but after 5sec on the starter if you wait 10sec theres no pressure if you crank again it must buil up from 0 pressure again

Last edited by Tinyprins; 05-01-2019 at 06:21 PM.
  #20  
Old 05-01-2019
JeanLuke  JeanLuke is offline
Full Flexer
 
Join Date: Jul 2017
Location: SE Qld
Posts: 645
What Jeep do I drive?: WG
Likes: 88
Liked 119 Times in 92 Posts
Check out my Ride(s)
Default

Pressure going down when the engine is not running is normal. How long is "a while" to build up to 200 bar? Mine takes about one second (or slightly less) of cranking to fire, which is 250 bar. It certainly is not instant. This is normal. If it is 3 or 4 seconds (or more) then there is a problem.
Sponsored Posts
  #21  
Old 06-01-2019
Tinyprins's Avatar
Tinyprins  Tinyprins is offline
Newbie
 
Join Date: Dec 2018
Posts: 31
What Jeep do I drive?: WJ
Likes: 2
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JeanLuke View Post
Pressure going down when the engine is not running is normal. How long is "a while" to build up to 200 bar? Mine takes about one second (or slightly less) of cranking to fire, which is 250 bar. It certainly is not instant. This is normal. If it is 3 or 4 seconds (or more) then there is a problem.
For sure 3 to 5 seconds not 1 or 2

Sent from my GT-I9500 using Tapatalk
  #22  
Old 06-01-2019
Tinyprins's Avatar
Tinyprins  Tinyprins is offline
Newbie
 
Join Date: Dec 2018
Posts: 31
What Jeep do I drive?: WJ
Likes: 2
Liked 0 Times in 0 Posts
Default

Im going to take the high pressure pump off and send it to bosch and have it tested ..will see what happens

Sent from my GT-I9500 using Tapatalk
Sponsored Posts
  #23  
Old 06-01-2019
JeanLuke  JeanLuke is offline
Full Flexer
 
Join Date: Jul 2017
Location: SE Qld
Posts: 645
What Jeep do I drive?: WG
Likes: 88
Liked 119 Times in 92 Posts
Check out my Ride(s)
Default

If you have it running, stop it and try a restart straight away (say within 10 seconds of fully stopping) does it start quicker? If so, you probably have a slow air leak between the tank and the LP pump.

Another cheap & easy check is to install a non-return (check) valve in the rubber line between the filter and the steel line from the tank.
  #24  
Old 06-01-2019
bodgie's Avatar
bodgie  bodgie is offline
Lowranger Shocker
 
Join Date: Aug 2009
Location: Castle Hill, NSW
Posts: 1,734
What Jeep do I drive?: WG
Likes: 1
Liked 193 Times in 154 Posts
Default

Have you replace the fuel pressure regulator at all?

The injector leak back results look OK to me but they could be confusing the pressure regulator too, does the car run well in the return line in disconnected?

Jason
Sponsored Posts
  #25  
Old 06-01-2019
Tinyprins's Avatar
Tinyprins  Tinyprins is offline
Newbie
 
Join Date: Dec 2018
Posts: 31
What Jeep do I drive?: WJ
Likes: 2
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JeanLuke View Post
If you have it running, stop it and try a restart straight away (say within 10 seconds of fully stopping) does it start quicker? If so, you probably have a slow air leak between the tank and the LP pump.

Another cheap & easy check is to install a non-return (check) valve in the rubber line between the filter and the steel line from the tank.
It can run for an hour if i switch it off and try to start again nothing cranks forever until i spray quick start

Sent from my GT-I9500 using Tapatalk
  #26  
Old 06-01-2019
Tinyprins's Avatar
Tinyprins  Tinyprins is offline
Newbie
 
Join Date: Dec 2018
Posts: 31
What Jeep do I drive?: WJ
Likes: 2
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bodgie View Post
Have you replace the fuel pressure regulator at all?



The injector leak back results look OK to me but they could be confusing the pressure regulator too, does the car run well in the return line in disconnected?



Jason
New regulator from mb ..havent disconnected the return while engine is running

Sent from my GT-I9500 using Tapatalk
  #27  
Old 06-01-2019
Tinyprins's Avatar
Tinyprins  Tinyprins is offline
Newbie
 
Join Date: Dec 2018
Posts: 31
What Jeep do I drive?: WJ
Likes: 2
Liked 0 Times in 0 Posts
Default

I have started it yesterday engine was cold its making a grunting effect when idling grunt grunt grunt ..like its loosing pressure the pump has 12month gaurantee from july last year so will send it monday back to bosch to have tested will ask if they can test the fuel regulator aswell

Sent from my GT-I9500 using Tapatalk
Post New Thread  Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


» Advertisements_AS2


Powered by vBadvanced CMPS v3.2.3



All times are GMT +10. The time now is 12:23 PM.




AJOR does not vouch for or warrant the accuracy, completeness or usefulness of any message, and are not responsible for the contents of any message. The messages express the views of the author of the message, not necessarily the views of AJOR or any entity associated with AJOR, nor should any advice be substituted as technical advice replacing that of a mechanic. You agree, through your use of this service, that you will not use AJOR to post any material which is knowingly false and/or defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, religious, political or otherwise violative of any law. You agree not to post any copyrighted material unless the copyright is owned by you or by AJOR. The owner, administrators and moderators of AJOR reserve the right to delete any message or members for any or no reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold harmless AJOR, the administrators, moderators, and their agents with respect to any claim based upon transmission of your message(s). The use of profile signatures to intentionally mislead or misdirect any member on this forum is not acceptable and may result in your account being suspended. Any trip that is organised through the AJOR forum is participated at your own risk. If you or your vehicle is damaged it is your responsibility, not that of the person that posted the thread, message or topic initiating the trip, nor the organisers of AJOR or moderators of any specific forum. This forum and associated website is the property of AJOR.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

AJOR 2002 - 2019 AUSJEEPOFFROAD.COM. All corporate trademarked names and logos are property of their respective owners. Ausjeepoffroad is in no way associated with DaimlerChrysler Corporation or Fiat Jeep.
www.ausjeep.com www.ausjeep.com.au www.midlifemate.com ausjeepforum.com Jeep Wrangler JL Australia release
vB Ad Management by =RedTyger=