Random stalling - AUSJEEPOFFROAD.COM - AJOR


Go Back   AUSJEEPOFFROAD.COM - AJOR > JEEP GARAGE > ZJ WJ WG Grand Cherokee


Portal Register Forums Trading Your Jeep New Garage Mark All Read

Post New Thread  Reply
 
Thread Tools Search this Thread
  #1  
Old 1 Week Ago
Smakked  Smakked is offline
Established Member
 
Join Date: Nov 2014
Posts: 105
What Jeep do I drive?: XJ
Likes: 10
Liked 28 Times in 16 Posts
Check out my Ride(s)
Default Random stalling

Hi guys. Have an issue with mine occasionally stalling when pulling up to lights etc. It sorted lurches forward and either stalls or I put it in neutral to stop it stalling.
I have replaced TPS but issue persists. Maybe it is IAC valve?

Any thoughts and suggestions welcome

No codes showing for this.

EDIT: Its athe 4.7 Non HO

Last edited by Smakked; 1 Week Ago at 06:35 AM.

Sponsored Posts
  #2  
Old 1 Week Ago
skipperau's Avatar
skipperau  skipperau is offline
CrawlerStar
 
Join Date: Apr 2009
Location: Brisbane Southside
Age: 54
Posts: 458
What Jeep do I drive?: WJ
Likes: 55
Liked 115 Times in 91 Posts
Default

It could be as simple as an issue with the torque converter. Or I had a CPS go on me giving those same symptoms.


Sent from my iPad using Tapatalk
  #3  
Old 1 Week Ago
KJ Ash's Avatar
KJ Ash  KJ Ash is offline
Established Member
 
Join Date: Oct 2007
Location: Sydney
Age: 40
Posts: 209
What Jeep do I drive?: WJ
Likes: 1
Thanked 4 Times in 1 Post
Default

Need codes (do the 3 turn key trick) and some more info. Does it only happen when it's warmed up and will it start back up after stalling?

Sounds kind of similar to an issue I had which ended up being the cam position and crank angle sensors.
  #4  
Old 1 Week Ago
Smakked  Smakked is offline
Established Member
 
Join Date: Nov 2014
Posts: 105
What Jeep do I drive?: XJ
Likes: 10
Liked 28 Times in 16 Posts
Check out my Ride(s)
Default

Quote:
Originally Posted by KJ Ash View Post
Need codes (do the 3 turn key trick) and some more info. Does it only happen when it's warmed up and will it start back up after stalling?

Sounds kind of similar to an issue I had which ended up being the cam position and crank angle sensors.
No Codes showing, even on a scan tool. Yeah have ordered both sensors along with IAC
Sponsored Posts
  #5  
Old 6 Days Ago
KJ Ash's Avatar
KJ Ash  KJ Ash is offline
Established Member
 
Join Date: Oct 2007
Location: Sydney
Age: 40
Posts: 209
What Jeep do I drive?: WJ
Likes: 1
Thanked 4 Times in 1 Post
Default

Quote:
Originally Posted by Smakked View Post
No Codes showing, even on a scan tool. Yeah have ordered both sensors along with IAC
You going Mopar parts?
  #6  
Old 6 Days Ago
Straubz  Straubz is offline
Established Member
 
Join Date: Jun 2014
Location: Yarra Valley Vic
Posts: 106
What Jeep do I drive?: WJ
Likes: 4
Liked 50 Times in 30 Posts
Default

I have the same problem, only does it when cold, doesn't show any codes or anything, just locks in first gear and won't allow any slip for stopping.
Sponsored Posts
  #7  
Old 5 Days Ago
Smakked  Smakked is offline
Established Member
 
Join Date: Nov 2014
Posts: 105
What Jeep do I drive?: XJ
Likes: 10
Liked 28 Times in 16 Posts
Check out my Ride(s)
Default

Quote:
Originally Posted by KJ Ash View Post
You going Mopar parts?
Nah just whats on rockauto, never had an issue with any other sensors
Post New Thread  Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On





All times are GMT +10. The time now is 12:00 AM.




AJOR does not vouch for or warrant the accuracy, completeness or usefulness of any message, and are not responsible for the contents of any message. The messages express the views of the author of the message, not necessarily the views of AJOR or any entity associated with AJOR, nor should any advice be substituted as technical advice replacing that of a mechanic. You agree, through your use of this service, that you will not use AJOR to post any material which is knowingly false and/or defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, religious, political or otherwise violative of any law. You agree not to post any copyrighted material unless the copyright is owned by you or by AJOR. The owner, administrators and moderators of AJOR reserve the right to delete any message or members for any or no reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold harmless AJOR, the administrators, moderators, and their agents with respect to any claim based upon transmission of your message(s). The use of profile signatures to intentionally mislead or misdirect any member on this forum is not acceptable and may result in your account being suspended. Any trip that is organised through the AJOR forum is participated at your own risk. If you or your vehicle is damaged it is your responsibility, not that of the person that posted the thread, message or topic initiating the trip, nor the organisers of AJOR or moderators of any specific forum. This forum and associated website is the property of AJOR.





Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

AJOR 2002 - 2017 AUSJEEPOFFROAD.COM. All corporate trademarked names and logos are property of their respective owners. Ausjeepoffroad is in no way associated with DaimlerChrysler Corporation or Fiat Jeep.
www.midlifemate.com wayalife.com jkwrangler.com ausjeepforum.com jk-forum.com canadianjeepoffroad.com 20secondgorilla.com
vB Ad Management by =RedTyger=